Frequently Asked Questions

Below is a compilation of our most commonly asked questions and theme issues.

I purchased a theme and I haven’t received my files.

  1. Please check your spam folder, as sometimes our emails can end up there.
  2. If you created an account, you can sign in to your account and download your files.
  3. Still don’t have your files? Contact us and we’ll get them to you asap!

I don’t have the option to upload the theme.

This is probably because your WordPress blog is not self-hosted. As a WordPress.com user, you do not have the ability to upload themes. As we state in each product description as well as our terms, our themes are for self-hosted WordPress sites only. We do not provide refunds due to incompatibility with WordPress.com.

I’m attempting to upload the theme, but my folder is not zipped.

The file that you upload is the zip file that you downloaded from us. You don’t have to extract the file or search for folders within that file to upload. Just upload the entire original download.

It is also possible that your browser is automatically extracting the zip file. This is common with the Safari browser. Try downloading your file using a different browser if this is happening.

You can also try the following steps in Safari:

  1. Open Safari
  2. Click Preferences
  3. Uncheck the option Open “safe” files after downloading

The mobile version isn’t showing correctly.

If you’re using the JetPack plugin, make sure you’re not using the mobile theme provided by the plugin. This is usually the reason for the mobile version of the theme not displaying correctly.

The changes I make are not showing up on my blog.

Are you using a caching plugin such as WP Super Cache or W3 Total Cache? If so, try clearing your cache. A lot of times, when using a caching plugin, you have to clear your cache in order to see your recent changes.

My images aren’t showing up in the post excerpts.

The theme pulls your “featured image” for post excerpts. Be sure to set a featured image in order for your image to appear.

The post excerpt view isn’t working.

In your blog layout options (Appearance > Customize > Blog Layout > Excerpt Automatic), and try selecting “No” under excerpt automatic, and the re-selecting “Yes.” It may just need a refresh, and that usually helps. Don’t forget to save your changes.

My post thumbnails aren’t displaying at the proper size.

Because you’re using a new theme, you’re also using new thumbnail sizes. Download the Regenerate Thumbnails plugin, and use it to regenerate your images. This will allow all of your images thumbnails to display at the proper size.

The slider isn’t displaying on my static page.

The slider is a “blog page slider,” which means once activated it will only automatically appear on your blogs home page.